Intereting Posts
Лучшая помощь для bash? Фрагментация и ext4 Как мне постоянно синхронизировать системные часы с аппаратными часами? Когда процесс перейдет в состояние «D»? exim4 на debian 7.8 отправлено письмо никогда не приходит @gmail Заблокирована машина Ubuntu fetchmail для регистрации полных сообщений И переход в mda Как определить уровень исправления для RedH при установке Enterprise Linux (RHEL)? Назначение команды переменной mount: специальное устройство / tmp / cdrom не существует – CentOS kickstart% post section Как я могу добавить подкаталог bin определенного каталога в PATH, чтобы иметь возможность запускать программные приложения из любого каталога? удалите бит на бит бит wget Копирование ОС с одного диска на другой, переходящего из MBR в GPT, – что нужно отслеживать? Можно ли задать шрифт лицом по комментариям файла в Emacs? Postfix: Исходящий фильтр электронной почты + отправка отправленного письма в папку

Получение ошибочной опции «-asroot» на пакетах

При попытке установить пакет kodi-standalone-service, однако после получения запроса на редактирование PKGBUILD, я получаю эту ошибку.

makepkg: invalid option '--asroot' Unable to read PKGBUILD 

Кажется, я ничего не могу найти с помощью Google. Это также происходит и в пакете ISL. (Кстати, я использую Yaourt, чтобы установить это)

Pacman 4.2 был официально выпущен всего несколько дней назад. Одним из его изменений является удаление опции --asroot из makepkg , что означает, что вы больше не можете создавать пакеты в качестве пользователя root.

Рекомендуемое решение теперь состоит в том, чтобы создавать пакеты с учетной записью non-root.

Вы можете больше узнать об этом изменении на посту Уолтера (он является разработчиком pacman).

Также есть некоторые дискуссии о мотивации этого изменения в списке рассылки архивных общих списков.

Опция --asroot была удалена. См. Журнал изменений pacman .

Поэтому вам нужно прекратить выдавать yaourt с помощью sudo