Intereting Posts
Как печатать нечетные нумерованные поля из текстового файла с помощью awk в Unix? Преобразуйте файл с разделителями табуляции, чтобы использовать символы новой строки Как определить долю samba, чтобы каждый пользователь мог видеть только свой дом? Добавление панели во второй монитор можно заморозить процесс в Linux и перезагрузить или выключить компьютер. Затем продолжайте процесс, который был заморожен? Греп из строки в строку Изменение носителей при установке apache2 Объединить строки с совпадающим первым столбцом Можно ли отключить одну панель в XFCE? Почему висит проклят? Петля, чтобы проверить, установлен ли пакет Debian или нет. Извлечение аудио из видео без преобразования в пользовательских действиях Thunar Как создать пул lvm по умолчанию на lxd v3 Как ядро ​​информирует демон OSPF о статусе физического интерфейса? Извлечь файл из полностью отключенной машины, возможно, через сообщения ядра

Проблема с поврежденными пакетами, пытающаяся установить python-dev

Мне нужно установить python-dev, чтобы установить другое приложение, но когда я делаю sudo apt-get install python-dev я получаю: The following packages have unmet dependencies: со списком зависимостей. Поэтому я добавил их, пока не было больше зависимостей, оставив командную строку как: sudo apt-get install python-dev libpython2.7-dev python2.7-dev libexpat1-dev libexpat1 .

После этого я получаю:

 The following packages have unmet dependencies: libexpat1-dev : Depends: libexpat1 (= 2.1.0-6+b3) but 2.1.0-6+deb8u1 is to be installed E: Unable to correct problems, you have held broken packages. 

Я открыл Synaptic и искал сломанные пакеты, но их не было. Я также пытался использовать aptitude вместо apt-get:

  The following NEW packages will be installed: libexpat1-dev{ab} libpython-dev{a} libpython2.7-dev{a} python-dev python2.7-dev{a} 0 packages upgraded, 5 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B/19.0 MB of archives. After unpacking 31.6 MB will be used. The following packages have unmet dependencies: libexpat1-dev : Depends: libexpat1 (= 2.1.0-6+b3) but 2.1.0-6+deb8u1 is installed. The following actions will resolve these dependencies: Keep the following packages at their current version: 1) libexpat1-dev [Not Installed] 2) libpython-dev [Not Installed] 3) libpython2.7-dev [Not Installed] 4) python-dev [Not Installed] 5) python2.7-dev [Not Installed] Accept this solution? [Y/n/q/?] 

Пока что так хорошо (я думал), поэтому я нажал «Y», но он перечислил множество пакетов для удаления и попросил меня продолжить. Поскольку у меня были сомнения по этому поводу, я нажал «n», но теперь, когда я делаю это снова, чтобы скопировать пакеты, предлагаемые для удаления, он ничего не делает:

 No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B of archives. After unpacking 0 B will be used. 

Любая помощь будет оценена. Заранее спасибо.

РЕДАКТИРОВАТЬ:

Сейчас я работаю с локальным репозиторием, так как у меня возникают проблемы с подключением к debian ftp (возможно, из-за сетевого администратора или прокси-сервера). Поэтому мои источники.lst:

 #deb http://ftp.debian.org/debian/ jessie main contrib non-free #deb-src http://ftp.debian.org/debian/ jessie main contrib non-free #deb http://security.debian.org/ jessie/updates main contrib non-free #deb-src http://security.debian.org/ jessie/updates main contrib non-free # jessie-updates, previously known as 'volatile' # A network mirror was not selected during install. The following entries # are provided as examples, but you should amend them as appropriate # for your mirror of choice. # #deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free #deb-src http://ftp.debian.org/debian/ jessie-updates main contrib non-free ##Local Repository deb file:/media/ramon-debian/JimiHendrix/debian8repo/debian jessie main contrib non-free deb file:/media/ramon-debian/JimiHendrix/debian8repo/debian stable main contrib non-free 

В репозитории вы используете что-то не так. https://tracker.debian.org/pkg/expat показывает, что в Debian нет пакета libexpat1_2.1.0-6+b3

Удалите rm -rf /var/lib/apt/lists/* apt с помощью rm -rf /var/lib/apt/lists/* а затем apt-get update снова. Если ваше местное зеркало в порядке, у вас должен быть рабочий (последовательный) список доступных пакетов. Если нет, то локальное репо прерывается …

Задача решена! Я загрузил пакеты libexpat1_2.1.0-7_amd64.deb и libexpat1-dev_2.1.0-7_amd64.deb из ссылки @Jan и установил их с dpkg -i package.deb .

Используйте инструмент aptitude – вы увидите это предложение много, но без инструкции. У меня была аналогичная проблема с сборкой GNU Radio PyBOMBS (на Raspberry Pi 3b, FWIW), которая не исправляла бы количество изменяющихся зеркал, rm -rf /var/lib/apt/lists/* или apt-get clean .

Если у вашего зеркала есть целевой пакет, исправление aptitude для меня было отрицать первое решение, которое, как вы пережили, ничего не делало. Затем вторым решением было понижение, которое установило необходимую зависимость!

Я бы получил:

 libevent-dev : Depends: libevent-2.0-5 (= 2.0.21-stable-2) but 2.0.21-stable-2+deb8u1 is to be installed 

Это решение для меня (для libevent-dev, но должно работать для libexpat1-dev):

 # aptitude install libevent-dev The following NEW packages will be installed: libevent-core-2.0-5{a} libevent-dev{b} libevent-extra-2.0-5{a} libevent-openssl-2.0-5{a} libevent-pthreads-2.0-5{a} 0 packages upgraded, 5 newly installed, 0 to remove and 0 not upgraded. Need to get 506 kB of archives. After unpacking 1586 kB will be used. The following packages have unmet dependencies: libevent-dev : Depends: libevent-2.0-5 (= 2.0.21-stable-2) but 2.0.21-stable-2+deb8u1 is installed. The following actions will resolve these dependencies: Keep the following packages at their current version: 1) libevent-dev [Not Installed] Accept this solution? [Y/n/q/?] n The following actions will resolve these dependencies: Downgrade the following packages: 1) libevent-2.0-5 [2.0.21-stable-2+deb8u1 (now) -> 2.0.21-stable-2 (stable)] Accept this solution? [Y/n/q/?] y The following packages will be DOWNGRADED: libevent-2.0-5 The following NEW packages will be installed: libevent-core-2.0-5{a} libevent-dev libevent-extra-2.0-5{a} libevent-openssl-2.0-5{a} libevent-pthreads-2.0-5{a} 0 packages upgraded, 5 newly installed, 1 downgraded, 0 to remove and 0 not upgraded. Need to get 641 kB of archives. After unpacking 1552 kB will be used. Do you want to continue? [Y/n/?] y 

После этого я мог бы возобновить сборку PyBOMBS с помощью зависимых зависимостей (ну, после выполнения аналогичного исправления для libboost-dev …).