Как использовать 32 бита и 64 бит Java на Debian?

Я запускаю Linux Mint LMDE на 64-битной машине. Я установил OpenJDK 64bits: 7u21-2.3.9-5, который используется некоторыми приложениями. В IceWeasel установлен плагин Iced-Tea 1.3.2 (64 бит).

Теперь я хочу использовать некоторые веб-сервисы, такие как Webex или Yugma. Но для этих сервисов требуется поддержка Java 32 бит. Они не работают с 64-битной Java.

Я попытался установить версию 32-битной версии Java с веб-сайта Oracle, но любая версия Java -version всегда возвращает это:

java-версия "1.7.0_21"

Рабочая среда OpenJDK (IcedTea 2.3.9)

(7u21-2.3.9-5) 64-разрядная виртуальная машина OpenJDK (сборка 23.7-b01, смешанный режим)

Возможно ли иметь 32 бит и 64 бит Java на одной машине?

Как установить и выбрать версии?

Как поменять 32-битные и 64-битные плагины на Iceweasel?

Пакеты openjdk Debian отмечены Multi-Arch: same что вы должны уметь:

  • sudo dpkg -add-architecture i386
  • Обновление sudo apt-get
  • sudo apt-get install icedtea-6-plugin

Возможно, вам придется сначала удалить версию плагина браузера amd64, но вы можете одновременно установить обе версии Java.